Nero CD Speed

Nero CD Speed Help version 1.00

Introduction

Nero CD Speed is a benchmark which can test the performance of CD-ROM drives, DVD-ROM drives and recorders.

There are also several extra functions to check the disc quality, test the overburning capacity, retrieve disc information, etc.


Basic Tests

Transfer Rate
DAE Quality
Seek/Access Times
CPU Usage
Burst Rate
Spin Up/Down Times
Load/Eject Times

Create Data CD

The basic tests can be run by pressing the Start button or by selecting a specific test from the Run Test menu.
If the Start button is pressed the selected tests are executed.
The selection of the tests can be made in the options screen.


Transfer Rate Test

The Transfer Rate Test measures the data transfer rate and displays the results in a graph.

There are two lines drawn during the test:
The green line shows the Transfer Rate.
The yellow line shows the rotation speed in RPM x 1000.

You can insert different types of discs to measure different kinds of performance.

Data CD, DVD

Data read speed will be measured.

Audio CD
DAE (Digital Audio Extraction) speed will be measured.

Blank CD-R(W):
Data write speed will be measured.

CD Speed will not write any data on the disc so you can still use your CD-R(W) after running the test.
If SAO is selected (see Options) the leadin is written (simulated) before the transfer rate is measured which means it can take a while before you will see some results.

The disc has to be written (simulated) completely and therefore the Test length option has no effect.

The Transfer Rate test also determines the reading type of the drive (CLV, CAV, P-CAV or Z-CLV).
The pictures below show the differences between each type.

CLV | CAV | P-CAV | Z-CLV

Options

Test length
By moving the slider you can select the accuracy. A higher accuracy will show a more detailed graph but the test will take longer.

High resolution graph
When this option is enabled, the graph will be more detailed and more data is tested.

Show RPM
Show or hide the rotation speed (yellow line).

Maximum speed CD
Maximum speed which can be displayed when a CD is inserted.

Maximum speed DVD
Maximum speed which can be displayed when a DVD is inserted.

Buffer underrun protection
Enables/disables buffer underrun protection if available.
It is recommended to leave this option checked when testing the write performance.
Buffer underrun protection is required for Z-CLV write modes.

Write mode
You can select either TAO (Track At Once) or SAO (Session At Once).

If SAO is selected you can also choose to overburn the disc.
When Overburn is enabled Nero CD Speed will measure the write performance until an error occurs.
This makes it possible to test the full capacity of 90/99/100min CD-R's.
Because the maximum allowed time code is 79:59.74, you must overburn these high capacity CD-R's to use the full capacity.

Disc Type (simulation only)
When the transfer rate test is executed with a blank disc is inserted, the write speed is measured.
You can choose to simulate writing an audio or a data CD.
Some high speed recorders can write data CD's faster than audio CD's and some recorders can only overburn audio CD's.


DAE Quality Test

The DAE Quality Test measures how well the drive can extract audio tracks.
First some audio sectors are extracted to the HD at three different locations on the CD.
The same sectors are read again and compared to the sectors written to HD.
Depending on the number of differences, the DAE quality will be rated from 0 to 10.
10 means perfect DAE (no differences).

Next Nero CD Speed will try to determine whether the drive supports accurate streaming.
When accurate streaming is not supported the drive is unable to locate the requested audio location at any time.

If your drive does not get a perfect score with this test (10/10 and Accurate Stream checked) it is highly recommended to use a CD ripper with a verify function to extract audio tracks.
Nero CD DAE is such a program which can be downloaded free of charge at http://www.cdspeed2000.com.


Seek/Acces Times Test

With this test the random, 1/3 stroke and full stroke seek/access times are measured.

Random: pickup is moved to random positions on the disc.
1/3: pickup moves from the start of the disc to 1/3rd of the length of the disc.
Full: pickup moves from the start of the disc to the logical end of the disc.

Options

You can choose to measure the Access times or the Seek times.

Difference between Access and Seek times
With the Seek Times test the pickup moves to the requested position.
With the Access Times test the pickup moves to the requested position and a single sector is read.
Access times are slightly higher, usually a few milliseconds.

The Number of operations is the number of times the pickup will move for each test.


CPU Usage Test

The CPU utilization at 1X, 2X, 4X and 8X is measured.


Burst Rate Test

The Burst Rate Test measures the transfer rate from the host adapter to the drive.

Please note that the results are only accurate if the drive caches the data.
Since many drives don't cache audio data it is recommended to use this test with data cd's.


Spin Up/Down Test

For high speed drives it is necessary to spin down the drive to lengthen the life of the optical parts.
The spin up test measures how long it takes before the drive can read data after it has stopped.
Shorter times are better.
Faster drives will have higher spin up/down times.


Load/Eject Test

This test will measure the time it takes for a drive to eject, load and recognize a disc.
The time needed to recognize a disc depends on the type of disc.
For example a drive needs much more time to recognize a multisession disc than a single session disc.
The eject and load times should always be about the same regardless of which disc is used.

Example of test results:

Disc | Eject time | Load time | Recognition time
1 | 1.84 sec | 1.31 sec | 3.85 sec
2 | 1.84 sec | 1.30 sec | 12.10 sec
3 | 1.84 sec | 1.31 sec | 4.45 sec


Create Data CD

This function will write predefined data in a selectable number of files on a blank CD-R(W) disc.
Data is written until the last sector which makes the disc very suitable to test the read performance.
While the disc is created the write performance is shown in the same way as the Transfer Rate test.

In combination with the standard tests such as the Transfer Rate and Seek Times test, both the read and write performance can be tested in a single pass.

There is also a verify function available which checks the data on the test disc.


File Functions

Load/Save Results
Database
Export Results


Load/Save Results

After a test has completed you can save the results to a binary file.
You can load a single file in Nero CD Speed to display the results on the main screen.
You can also load multiple files to compare results from different drives by using the Database function.


Database

This function allows you to load binary results files to compare the results.
The tests must have been done with the same disc.

After the files have been loaded you can display the results from a specific test.
To see a graphical presentation of the results press the Graph button.
You can specifiy which results you want to view by using the checkboxes.


Export Results

You can export the test results to a text file or a HTML file.
If you export to an HTML file, the tranfer rate graphs will be saved to seperate .PNG files.


Extra Functions

Advanced DAE Quality Test
Overburning Test
CD Quality Test
ScanDisc
CD-R Info


Advanced DAE Quality Test

The Advanced DAE Test will reveal all DAE problems a drive may have.
By using a special test disc, which must be created with Nero CD Speed, even the smallest error will be detected.
There are two kinds of errors which can occur:

Data Errors
These are just audio samples which are read incorrectly.
The cause of these errors is usually bad media. A solution is to use different media or decrease the drive's speed.
If the number of data errors is not too high you probably won't hear them because the internal error correction routines of the drive should be able to fix them.
Nero CD Speed detects them by comparing the read bytes with the known data from the test disc.

Sync Errors
A sync error occurs when the drive does not read the audio sector requested by the application but a sector near it.
For example when the application requests sector 1000 the drive may return the data from sector 999.
When this happens either some samples are missing or samples are repeated. This error is probably audible.
The test disc contains data which allows Nero CD Speed to determine whether the correct sector is read.

The sequential read test simulates DAE under perfect conditions. Most drives will pass this test without errors.
The harmonica read test is very though for the drive. Many drives will not pass this test without errors.
Based on the number of errors a score is given. A score of 100.0 is a perfect score.

After checking the DAE quality, the test will determine whether the drive can be used in combination with a recorder to make backups of audio discs on the fly.
The test will check if an audio disc can be copied without any errors at different speeds ranging from 1-16X.

Finally some advanced features of the drives are tested:

Offset
All drives start reading audio sectors at a different position from the actual start position.
This offset is usually a few 100 samples. Also recorders don't start writing at the start position.
Nero CD Speed reports the total of the read offset of the tested drive and the write offset of the recorder which was used to create the test disc.

Read Leadin
To make perfect copies a drive should be able to read data before the start position (see offset explanation).

Read Leadout
To make perfect copies a drive should be able to read data from the leadout (see offset explanation).

CD Text
Checks the drive's ability to return CD Text information.

Read Subchannel Data
Subchannel data contains information such as index markers, track number, etc..
A drive must be capable of returning this information to make perfect audio copies.


Overburning Test

With the overburning test you can check whether your recorder supports overburning and how much data can be overburned on a particular CD-R(W) disc.

To run the test first insert a blank CD-R(W) disc. Nothing will be written on the disc.
Then select the recording speed and the test capacity.
The test capacity should be higher than the official capacity.
Also note that many recorders refuse to write beyond 90 minutes. This is important when you're testing 99 minute CD-R's.

During the test you can see the recording progress.

Position: current write position.
Relative: position relative to the official capacity.

Green bar: written data before the official capacity.
Yellow bar: written data beyond the official capacity (overburned part of the disc).
Dark green bar: data buffer.
Blue line: official capacity.
Red line: current/end position.

Disc information: official capacity, manufacturer, dye type and disc type.

If the test has completed successfully you can add the results to the list at the end of the screen.
You can delete entries with the delete key.

Notes
- The maximum capacity will be lower than the last written position because the recorder still has data in its buffer.
- You should not write until the very end of the maximum capacity. It is very likely that the area at the end of the disc is unreadable.

You can find more important information about overburning on the CD Speed website.


CD Quality Test

The CD Quality Test scans the disc for errors (yellow line ) and shows the read speed (green line ).

It can be useful to:

- Compare the recovery strategy of different drives when a low quality or damaged CD is used.
- Check the quality of the CD(-R/W) media
- If you have a CD recorder, you can check if the data on the CD-R(W) is written correctly but for this purpose the ScanDisc function is better suited.

The CD Quality Test can detect certain special test discs such as the Philips SBC 444 A.
These discs contain defects at specific locations. The defects are displayed on top of the screen.
The position of the defects on the screen match the positions of the defects on the disc.
Using these discs makes it very easy to check the error handling of drives.

Please note that not all drives are capable of returning error information.
To make sure your drive supports this feature you should run the test with a badly damaged disc. An audio disc is highly recommended for this because you will probably get a read error when you're trying to read from a badly damaged data disc.


ScanDisc

ScanDisc is a function which will show you the quality of a disc.
The test consists of two parts, the File Test which simply reads all files on the disc and reports all errors.
This test can also be used for benchmarking to give you an idea on how well the drive performs with for example software installing.
The Surface Scan checks the quality of each sector and shows the results in a graph.

This is an example of a severely damaged data disc. The yellow parts show damaged areas. For data CD's the data in these areas can be corrected. The red areas are unreadable. This means files are lost which is also indicated by the File Test.

This is another example of a badly damaged disc, this time an Audio CD. Unlike data CD's, the yellow areas are uncorrectable which means a loss of quality. The color tells you how badly the sectors are damaged. Bright yellow means only a few errors, dark orange means a lot of errors.

It is very rare to see unreadable areas on a Audio CD, so in this case the disc is extremely badly damaged.


CD-R Info

CD-R Info shows important information of a CD-R or CD-RW disc.

Manufacturer
Company name of the disc manufacturer. This is not the brand name.

Code
Each company has a different code.

Disc Type
CD-R or CD-RW.

Usage
General or Audio. Only Audio CD-R(W)'s can be used in stand-alone cd recorders.

Recording Layer
Type of recording layer.

Recording Speed
Minimum and maximum speed at which the disc can be written. This information is only available with CD-RW's.

Capacity
Blank capacity in MSF (Minutes:Seconds.Frames) and MB (MegaByte).

Additional Capacity
This field shows whether the disc has a capacity higher than 80 minutes.
This information is not available with all high capacity discs.

Overburn Capacity
Shows the maximum available capacity. This information is retrieved from the database of the Overburning Test.


How to use Nero CD Speed to...

...measure the performance
...check the media quality


Measure the performance

By executing the basic tests of Nero CD Speed you will get an accurate view of the performance of your drive.

Here are some things to consider when testing:

1) Use a disc with large capacity
Most drives only reach the maximum speed at the very end of the disc.
To get accurate results the disc capacity should be 70 minutes or higher for CD's and 4 GB or higher for DVD's.

2) Don't use damaged/dirty discs
A disc with scratches or fingerprints on the surface is much more difficult to read. In most cases the drive will slow down and you will not see the maximum performance of the drive.

3) Don't run any CPU intensive tasks in the background
This will have a negative affect on the testresults.

4) Make sure your configuration is set up properly
For atapi drives DMA must be enabled (if supported).
For SCSI drives, the SCSI card must be configured correctly.


Check the media quality

Checking the quality of media is important to know if your data is safe.
Nero CD Speed has some tools which can make this task very easy.

Data CD's

Verifying the quality of data discs (CD or DVD) is relatively easy.

1) Run ScanDisc
Check both the File Test and the Surface Scan.

If this test is executed without any errors then the files are all readable.
The Surface Scan can detect damaged areas if the drive can report C2 errors (most current drives do).

2) Run the Transfer Rate Test
Enable the High resolution graph in the options screen.

Running the Transfer Rate test will also tell you a lot about the quality of the disc.
If a drive has trouble reading a sector on a data disc, it will retry the read operation and/or decrease the speed.
The graph below demonstrates this. So even though the files on the disc are all retrievable, the quality of the disc is poor because the drive needs to read some sectors several times to return the data without errors.

If the drive is unable to read a sector it will return an error.

Audio CD's

Checking the quality of audio cd's is a bit more difficult.
Data discs have an extra level of error detection/correction which makes the data stream much more reliable.
The problem with audio CD's is that drives behave differently when there are errors in the audio sectors.

A drive can use different strategies to handle errors in audio sectors.
This is demonstrated by running the CD Quality Check with different drives.
For the tests the Philips SBC444A test disc is used.

1) Drive ignores the errors and keeps reading at full speed.
If a drive uses this strategy it is highly recommended to use audio extraction tools with a verify option (such as Nero CD DAE) to extract audio tracks.

2) Drive slows down when errors are detected.
Drives who use this strategy will give better results when extracting audio.

3) Drive reads the sector with the errors again and slows down if necessary.
When a drive uses this strategy you usually don't have to worry about the quality since the drive will try very hard to return the requested sectors without any errors

Blank CD-R(W)'s

If you have a high speed recorder then it is very important that you use high quality media which is rated at the maximum write speed of your recorder.
Bu running the Transfer Rate test you can see the maximum speed at which a CD-R(W) can be written.

It's also a good idea to test the quality of a written CD-R(W) before you buy large quantities.
You can write data to a disc with either the Create Data CD function or the Advanced DAE Quality Test function.


Links

Data CD Test Results
Audio CD Test Results
DVD Test Results
Top 10

CD Speed Website
Nero Website


Contact Information

You can send your questions, remarks, etc. to support@cdspeed2000.com.

Before asking for technical support please check the FAQ's on the CD Speed website first.